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1. Introduction
Purpose of Imalytics Preclinical
Imalytics Preclinical aims to visualize and analyze multimodal preclinical image data sets using
interactive segmentation operations. It was developed by PD Dr. Felix Gremse at the Institute for
Experimental Molecular Imaging (ExMI), RWTH Aachen University Clinic, in cooperation with Philips
Research Aachen. It was commercialized by Gremse-IT GmbH, a spin-out of ExMI.
The software is described in these two papers. When using the software, please mention the name of
the software (Imalytics Preclinical) and cite this paper:
(1) F. Gremse, et al., “Imalytics Preclinical: Interactive Analysis of Biomedical Volume Data,”
Theranostics. 2016 Jan 1;6(3):328-41. (https://pubmed.ncbi.nlm.nih.gov/26909109/)
When using the CT-FMT protocol, please cite this paper:
(2) F. Gremse et al., “Hybrid µCT-FMT imaging and image analysis,” J Vis Exp. 2015 Jun 4;(100):e52770.
(https://www.ncbi.nlm.nih.gov/pmc/articles/PMC4512251/)
When using the improved FMT reconstruction, please cite this paper:
(3) F. Gremse et al., “Absorption reconstruction improves biodistribution assessment of fluorescent
nanoprobes using hybrid fluorescence-mediated tomography,” Theranostics. 2014 Jul 26;4(10):96071. (https://pubmed.ncbi.nlm.nih.gov/25157277/)
When using the software for stenosis measurement, please cite this paper:
(4) F. Gremse et al., “Virtual elastic sphere processing enables reproducible quantification of vessel
stenosis at CT and MR angiography,” Radiology. 2011 Sep;260(3):709-17.
(https://pubmed.ncbi.nlm.nih.gov/21788527/)
The software is preferably used for fast and accurate analysis of preclinical image data sets, especially
for the analysis of data acquired by computed-tomography (CT), fluorescence-mediated tomography
(FLT), ultrasound (US), positron emission tomography (PET), single-photon emission computed
tomography (SPECT), bioluminescence, and magnetic resonance (MR) imaging. The software is
recommended for the interpretation of multimodal imaging studies such as PET-CT, FMT-CT, SPECTCT, MRI-CT, PET-SPECT, and more.

The program allows processing and visualization of three data sets:
-

an underlay (e.g., CT in case of µCT-FMT imaging in Figure 1A)
a segmentation map (e.g., organ segmentation in Figure 1B), and
an overlay (e.g., three-dimensional fluorescence distribution in Figure 1C)

Figure 1: Visualization of image data sets using Imalytics Preclinical. (A) CT scan as an underlay. (B) Organ
segmentation (Lungs and Bladder) as a segmentation map. (C) A three-dimensional fluorescence distribution
as an overlay. (D) The underlay, segmentation map, and overlay can be shown together.

Underlay, overlay, and segmentation can be processed independently from each other. They can have
different sizes and transformation. Each voxel of the segmentation map is assigned to exactly one class,
e.g., “Bladder”, “Liver”, or “unclassified” which is the default. The segmentation is useful for
quantification, because parameters such as volumes and mean intensities can be computed.
3D data sets are usually processed, but 2D, 4D, and even 5D data sets can also be loaded and analyzed.
Typically, the fourth dimension is the time, as for longitudinal PET scans. The fourth dimension can also
represent different echo times from MRI relaxometry measurements. For 4D data sets, the
segmentation remains a 3D data set, however. The fifth dimension usually represents multiple
channels, e.g., from dual-energy CT or scanning with multiple wavelengths in the FMT.

Applications of Imalytics Preclinical
Segmentation
fast and easy automatic, semi-automatic, or manual segmentations of phantoms, regions of
interest (ROI), or complete organs
Image processing
processing and visualization of (i) an underlay (e.g. a CT image), a segmentation map (e.g.
whole body organ segmentation), and an overlay (e.g. three-dimensional fluorescence
distribution)
Multimodal imaging and image fusion
fusion, processing, and analysing multimodal image data such as optical-CT, nuclear-CT, MRIoptical, or MRI-CT data sets
image fusion via manual, image-based, or marker-based alignment of data sets
Oncology/ Cancer research
Accurately detect, segment, and characterize tumors, lesions, and metastases
Several types of tumors (subcutaneous, orthotopic, genetically induced, diet driven) such as
colon cancer, PDAC, liver lesions, and lung metastases
IMALYTICS Preclinical - User´s Manual
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Easy workflow to calculate SUV and %ID/g
Vascular analysis
Analysis of blood vessels, investigation of aortic aneurysms
Stenosis measurements
Atherosclerotic lesions
Angiogenesis
Pharmacokinetic
Kinetic modeling to determine organ biodistribution, elimination, and retention sites of of
novel drugs, therapeutics, or drug carrier systems
Assessment of antibody biodistribution in vivo, immunotherapy monitoring
Gastroenterology
Fat segmentation, subcutaneous and visceral fat ratios, gastroenterological issues
Hepatic vascular regeneration e.g., after partial hepatectomy
Organ volumes
Bone analysis
Evaluation and quantification of new bone formation
Calcifications
Dentistry, craniofacial surgery, investigation of skull and bone structures in different models
(rodents, fish)
Other applications
3D printing
Spectral unmixing
Relaxoemtry
Brain atlas
Porcine studies
Fish studies
Ballistic experiments

Technical Requirements
This program is available for Windows operating systems. It runs on permanently installed PCs
or laptop computers. Furthermore, it requires an NVIDIA GPU graphic card with CUDA compute
capability 3.0 or higher (https://developer.nvidia.com/cuda-gpus). Without a GPU, the program will
not start. The program requires a license. Without a license, or if the license is expired, it will not
start either.
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2. Installation
Installation of Imalytics Preclinical
Run the install file of the software:
Follow the installation steps, the default settings should be sufficient in most cases.

Wait until the installation is finished (depiction of a green progress bar) and launch the software.
The software will inform you when the installation is incomplete.
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Installation of graphic card driver
The software requires an NVIDIA GPU graphic card and a respective driver which is freely available at
NVIDIA (http://www.nvidia.com/page/home.html). Upon starting, Imalytics Preclinical may complain
and require installing a new driver.
-

At first, determine what graphics card is included in your computer. There are two ways to
check:
1) Open the control panel application> Hardware and Sound > Device manager > Graphic card >
click right mouse button > Settings
2) Press windows ( ) + R → Enter dxdiag → wait for one moment > Display (1) → Name: Graphic
card, for example NVIDIA Quadro P5000
-

Then, please open the NVIDIA website (http://www.nvidia.com/page/home.html)
Open drivers → ALL NVIDIA DRIVERS

-

Start Manual Driver Search

-

Choose Option 1 and enter your graphic card details.
Press SEARCH.
Download the driver by pressing the button DOWNLOAD.
Follow the download instructions and install the driver.
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3. Getting to know the software
Starting the program and loading your image data
After successfully installing Imalytics Preclinical, open the software. The splash screen will appear with
the software name and the installed version. Afterwards, you can load your image data by pressing
“File > Underlay > Load underlay” (see Chapter 4 Menu Bar > File Menu) and then select your image
file. The software will automatically create an empty segmentation (Class: Unclassified), i.e., a voxelwise map with the same dimensions as the underlay. You can also load an existing segmentation from
a file by “File > Segmentation > Load segmentation”. In case of multimodal imaging and for image
fusion purposes, you can load another image data set as overlay by pressing “File > Overlay > Load
overlay”.
If you want to practice with images from different modalities (CT, PET, SPECT, MRI, US, BLT, FLT) and
samples (mouse, bones, phantoms), you can use an example data set from the tutorials.

Video tutorials
Under “Help > Tutorials” (see Chapter 4 “Help Menu”) or Tutorial
in the upper toolbar, you can
play several movies showing how to use this software. The movies have built-in subtitles in English,
Chinese, German, French, and other languages which can be shown with a video player such as VLC.
You can also load information about the data set, the example data set that was used in the movie
itself, and a white paper for further information.

Project files (.imaproj)
The Imalytics Preclinical software offers to save the current project as a file for reloading (e.g., when
closing the program). This project file (.imaproj) contains the compressed segmentation and all
settings, e.g., the 2D and 3D view settings, and contains the relative paths to the underlay and overlay.
It does not contain the undo/redo information. It is recommended to save a segmentation or fused
image as project file, when you use it for a publication and you must correct it later (as it might be
asked by reviewers, for example).

Overview of the software
Main window
The main window (Figure 2) consists of a menu bar, panels to show different 2D slice views and the 3D
rendering, and a toolbar. Axial, coronal, and sagittal slice views and the 3D view can be toggled
independently. The viewing center (a point in 3D) is shown in each view as a red marker. The active
point is shown in green and can be reset with a right-click. Many segmentation operations use the
active point as a seed point.
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Figure 2: Main window. The main window consists of the menu bar, toolbar (including the upper toolbar, the
mouse settings toolbar, and the mouse mode toolbar), panels to show 2D slice views and 3D rendering, and
the context menu (right mouse button). The menu bar offers different operation modes. The toolbar is used
to set mouse modes and for viewing and segmentation operations. Most of the space is taken by the panels
to show the 2D slice views and the 3D rendering.

Menu bar
The menu bar will be explained in detail in Chapter 4.

Toolbar
The toolbar directly appears when you open the software. If the toolbar disappears, click on the menu
bar with the right mouse button and activate the tick box. The toolbar will immediately appear. The
toolbar includes the upper toolbar and the mouse mode toolbar.

Upper toolbar
Most functions of the upper toolbar are described in Figure 3.

Figure 3: Upper toolbar. Input and output classes can be selected. Undo and Redo can be performed. Axial,
coronal, and sagittal slice views and the 3D rendering can be toggled on/off independently. Linear
interpolation can be turned on and off. The crosshairs and markers, scale bars, and bounding boxes can be
toggled (show symbols). Different layers can be selected for further operations. The rendering of underlay,
overlay, and overlay for camera can be toggled in all views. The windowing dialogs can be opened for the
selected layer. Navigation is possible through channels, depending on the underlying data set. Tutorial
provides example data set and movies showing how to use the software.
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Figure 4: Undo/Redo. The inner part includes the operations that can be undone or recovered. Instead, the
outer part consists of these operations that cannot be undone or recovered.

Input: Select the input class.
Output: Select the output class.
Undo: Undo (revert) the last action, e.g., segmentation operation. Put the state on a stack for Redo.
The operations that can be undone or recovered are shown in the inner part of Figure 4.
Redo: Recover the next state from the undo/redo stack. The operations that cannot be undone or
recovered are shown in the outer part of Figure 4.
Axial view: Toggle the axial view on/off.
Coronal view: Toggle the coronal view on/off.
Sagittal view: Toggle the sagittal view on/off.
3D view: Toggle the 3D view on/off. The dropdown menu of the “3D view” will be explained in detail
in chapter 2 “Rendering Menu”.
Linear interpolation: Toggle the linear interpolation on/off. It is suitable for smoothing edges (i.e.,
Anti-aliasing).
Show symbols: Toggle all symbols on/off. The dropdown menu of the “Show symbols” will be
explained in detail in “View > Show symbols” under Chapter 4 “View Menu”.
Show segmentation: Toggle the segmentation on/off. This operation is done in all views. The
dropdown menu can toggle the selected class on/off, which is explained in detail in “Classes > Class
visibility…” under Chapter 2 “Classes Menu”.
Show layer: Toggle the layer on/off. This operation is done in all views. The dropdown menu of the
“Show layer” will be explained in detail in “View > Layer settings” under Chapter 4 “View Menu”.
Layer windowing: Adjust the selected layer windowing. Emphasize areas, e.g., soft tissue or bone
substance, by setting desired value range or threshold for the layer data. The dropdown menu of the
this operation will be explained in detail in “View > Windowing settings” under Chapter 4 “View Menu”.
Switch channel: Switch to the user-selected channel. You can also find them in the “Channels Menu”.
Channels > Previous channel: Go to the previous channel of the selected layer.
Channels > Next channel: Go to the next channel of the selected layer.
IMALYTICS Preclinical - User´s Manual
11

Tutorial: Load tutorials. The sub menu also provides example data set for every tutorial movie. You
can also find these operations in “Help > Tutorials” under Chapter 4 “Help Menu”.

Mouse settings toolbar
For some functions of the vertical/ mouse mode toolbar, a special toolbar under the upper toolbar will
appear. You can specify the operations of the selected mouse mode toolbar function.

Mouse mode toolbar
Most functions of the mouse mode toolbar are described in Figure 5.

Figure 5: Mouse mode toolbar. Different mouse actions (slice through, set view center, pan view, zoom,
rotate view, move through time, change clipping distance, draw scribbles, measure distance) can be
selected. The setting of the underlay windowing can be changed. Segmentation can be drawn directly, and a
region can be created for segmentation. An existing class can be moved or copied. For the images, there are
Crop, Clean, Fill region ISO and Fill region operation buttons. Markers can be created. The overlay image can
be moved or rotated for image fusion. The information of the selected voxel can be shown. You can create a
brain atlas and adjust it on the underlay.

The mouse can be used for many different operations, e.g., to select the viewing center or draw
scribbles. Some interactions work in the 2D views and some in 3D but most work in both. The current
mouse mode can be selected using the mouse action buttons in the mouse mode toolbar (Figure 5).
Alternatively, they can be selected using special combinations of mouse keys.
LMB = left mouse button

RMB = right mouse button

MMB = middle mouse button Wheel = scrolling-wheel
keyboard keys: SHIFT, ALT, and CTRL
Slice through: Slow: ALT + Wheel, fast: MMB. Scroll through axial, coronal, or sagittal slices.
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Set view center: CTRL + LMB. Center the view at the selected point (2D and 3D). This operation can
reset the viewing center. This operation is very useful when you want to center to a selected position,
for example, a special organ, tumor, or metastasis.
Pan view: MMB. Move the view (2D and 3D). Move all 2D views if pan view is applied to one of them.
The 3D view can be moved separately.
Zoom: CRTL + Wheel. Zoom in and out (2D and 3D). Zoom all 2D views if zoom is applied to one of
them. The 3D view can be zoomed separately.
Rotate view: ALT + LMB. Rotate the axial, coronal, sagittal, or 3D view interactively. Rotate all 2D views
when this operation is applied to one of them. The 3D view can be rotated separately.
Move through time: Slow: SHIFT + Wheel, fast: SHIFT + MMB. Move through different time points
when using 4D images. The dimensions of the data set is shown under “Options > Show image
information” (Chapter 4 “Options Menu”).
Interactively windowing: Change the underlay windowing settings of the selected layer (2D and 3D).
The setting of the underlay windowing can be changed and displayed directly by moving the mouse
cursor in a 2D view or 3D view.
Change clipping distance: CTRL + ALT + MMB. Change the clipping distance of the clipping plane.
Firstly, “View > Show clipping plane” (Chapter 4 “View Menu”) must be selected before change the
clipping distance.
Draw segmentation: Draw a segmentation with the mouse in the 2D and 3D views. The drawn region
is changed from the input to the output class. This operation only works on the input class. In 2D
view, it only works for a slice.
Create region: Create a region for segmentation. This operation can be done in 2D and 3D views.
Draw scribbles: SHIFT + LMB. Draw scribbles. Foreground and/or background scribbles are drawn om
any 2D view and placed into a 3D data set. The scribbles can be deleted (pressing F1), connected into
the “red shadow” (pressing F3), and accepted into the output class (pressing F4).
The drawing mode can be configured in the drop-down menu, which will be explained in detail in
“Scribble > Scribble settings” under Chapter 4 “Scribble Menu”.
Fill region ISO: A region growing operation is carried out, using the click position as seed point and the
intensity in the selected layer as threshold. The operation is restricted to the input class and the result
is assigned to the output class.
Fill region: Fill the selected region as an output class. The connected component of the click point is
assigned to the output class.
Copy or move class: Copy or move a class to a new position (2D and 3D). The class is selected with the
mouse cursor.
Show voxel info: Show voxel information by clicking on the respectively position (2D). The information
includes the world position, the underlay and overlay voxel intensities, and the class of the selected
voxel.
Create marker: Create a marker on the selected layer by clicking on the respective position in a 2D or
3D view. Marker name and color are assigned automatically if the option “Auto-name markers” is
selected.
IMALYTICS Preclinical - User´s Manual
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The drop-down menu of the marker action will be explained in detail under Chapter 4 “Markers Menu”.
Measure distance: CTRL + RMB. Measure the distance interactively between two points defined by
the LMB (2D and 3D). The measurement can be given a name and stored in the project file.
Image crop: Crop the selected layers to the drawn region (2D and 3D). The region can be drawn with
the mouse cursor. Only visible layers (and segmentation) are cropped, and the hidden layers keep the
same. Using this operation, the underlay, overlay, and segmentation can be cropped alone or together.
It means the segmentation is not required to have the same size as the underlay/overlay.
Interactively image fusion: Move or rotate the overlay interactively. This operation only changes the
transformation of the overlay, not the voxels.
Image clean 3D: Clean a view inside a specified area drawn with the mouse cursor (2D and 3D). All
voxels that are projected into this area are set to zero.
Image clean sphere 3D: Clean a view within a selected area considering a spherical
radius. The area can be selected with the mouse cursor. This operation can be done in 3D.
Brain atlas: Create a brain atlas. Rotate and zoom you underlay to align it with this atlas (pink
colour). Afterwards, you can generate a segmentation.

Mouse action modes:
Draw scribbles: SHIFT + LMB
Delete scribbles: SHIFT + RMB
Center view: CRTL + LMB
Slice through fast: MMB
Zoom in and out: CRTL + Wheel
Clipping distance: CTRL + ALT + MMB
Rotate view: ALT + LMB
Change windowing settings: ALT + RMB
Measure distance: CTRL + RMB

Other mouse operations
Set output class and open context menu: RMB
Slice through slow: ALT + Wheel
Go through time slow: SHIFT + Wheel
Go through time fast: SHIFT + MMB
Repeat last fill region action: SHIFT + ALT +LMB
Change an available layer: TAB
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Context menu
The context menu appears when clicking the right mouse button in one of the slice views (Figure 6).
Many of the operations can also be found in Chapter 4.

Figure 6: Context menu. It appears when right-clicking which also sets the active point and the input class.
The context menu is populated with many operations, which can also be reached through the menu bar. For
example, “Add class” can be called through “Classes > Add class” under Chapter 4 “Classes Menu”. These
operations are explained in detail in Chapter 4.

Context menu > Add Class: See “Classes > Add class” under Chapter 4 “Classes Menu”.
Context menu > Morphologic > Dilate, Erode, Open, Close, Coat: See “Segmentation > Morphologic”
under Chapter 4 “Segmentation Menu”.
Context menu > Thresholding > Above, Below, Range, Above center, Local (Above, Below): See
“Segmentation > Thresholding” under Chapter 4 “Segmentation Menu”.
Context menu > Smooth class: See “Segmentation > Smooth input class” under Chapter 4
“Segmentation Menu”.
Context menu > Hide class: Hide the selected input class. The hidden class can be shown by choosing
the class through “Show segmentation” in the upper toolbar or “Class > Class visibility…” under Chapter
4 “Classes Menu”.
Context menu > Assign input to output class: See “Segmentation > Assign input to output class” under
Chapter 4 “Segmentation Menu”.
Context menu > Fill region > Fill region unlimited, Fill region volume bounded, Fill region distance
bounded, Grow into output class, keep this component (despeckle): See “Segmentation > Fill region”
under Chapter 4 “Segmentation Menu”.
Context menu > Find components > Find small components, Find large components, Find largest
component, Find enclosed by: See “Segmentation > Find components” under Chapter 4
“Segmentation Menu”.

Context menu > Save image/movie:
Save screenshot: Save screenshot of the panel as a .png file. Please choose the folder where
you want to save the image.
Save rotation/time movie: Render movie with optional rotating around the Z-axis and
optionally with stepping through time. Set the duration of the movie [s], the desired rotation
during the movie [degree], desired time steps starting from current time (depending on the
selected layer), and the desired file size [MB] (0 for any). When the movie is ready, a window
with “Movie is rendered.” appears. Press OK to continue.
Measure frame rate: Measure the frame rate of this panel.
Reset camera position: Reset the camera position.
Save camera position: Save the current camera position as a .cam file.
Load camera position: Load a camera position from a .cam file.
Save depth map: Save the depth map (depth for each pixel) for this image.
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4. Menu bar
The menu bar is split into several sub menus that are described in detail here:

Figure 7: Overview of the complete menu bar. The menu bar includes many menus, e.g., “File Menu”, “Edit
Menu”, etc. Some menus which need special licenses are not listed here.

File Menu
The file menu allows you to open or save a project, an underlay, an empty or existing segmentation, a
single class, an overlay, an overlay for camera, or to exit the software. Supported file formats are listed
in Table 1. The file menu contains the following menu items:

File > Project

> Load project… (Ctrl + O): Load settings and segmentation from a project file
(.imaproj). Underlay and overlay are loaded as specified by relative file paths.
> Save project… (Ctrl + S): Save project file (.imaproj) with settings and segmentation.
Relative paths to the underlay and overlay are stored.
> Save project as…: Save project settings and segmentation as a new project file.
> Show project file path: Show file paths for the project, underlay, and overlay.
> Close project: Close the current project. You will be asked to save or discard the
project.

File > Underlay > Load underlay…: Load underlay from a selected file. Supported file formats are
shown in Table 1.
> Replace underlay (equal size): Replace the existing underlay with a new underlay
that must match the size.
> Load special: Allow reading special file formats, e.g., to load a set of 2D images as
one 3D image or load a set of 3D images as one 4D image. Also, the loading of raw files
is possible if the user provides the correct dimensions.

> Create image: Create an underlay. There are several options: sphere,
ellipsoid, cube, cylinder, Menger Sponge, Shepp-Logan phantom.
Furthermore, it is possible to create an empty underlay for an orphan
segmentation file, i.e., where the underlay is unavailable.
> Add time points: Load an image file and append it as time point(s). This
operation requires matching 3D/4D dimensions and voxel sizes.
> Add channels: Load an image file and append it as another channel(s). This
operation requires matching dimensions and voxel sizes.
> Open raw file: Open a raw image file and ask the user for the structure.
> Open 2D images as 3D…: load a set of 2D images as one 3D image.
> Open 3D images as 4D…: load a set of 3D images as one 4D image.
> Open sub image…: Load a file but only a rectangular sub-region.
> SkyScan downSampled by 2…: Load a Skyscan .log file and down-sample it
by 2 during loading to enable loading huge files too big for the PC to handle
directly.
> PerkinElmer FMT 2D…: Open a .fmt file from the PE FMT. Load the lamp
image as underlay and the fluorescence image as an overlay.
> PerkinElmer FMT 2D multi: Load a folder of PE .fmt files. Convert each .fmt
file into a parallel folder suitable for the batch mode.
MILabs OI 2D…: Open a MILabs .oi file.
> Inspect DICOM taq data: Open tree view for DICOM file.
> Open DICOMDIR file…: Open a DICOMDIR file and show a list of images for
selection.
> Open all DICOM files related to file in series…: Open a DICOM file and all
other DICOM files that belong to that file.
> Open single DICOM file from series…: Open a single DICOM file that belong
to that file.
> Show underlay properties: Show image information of the underlay.
> Save underlay as…: Save the underlay as a file. Several file formats are supported.
Some file formats may not support 3D files, resulting in an error message. When
selecting PNG, 3D files are stored as multiple files (only for 8bit PNGs).
> Save underlay as pyramid…: Save the underlay as multiple down sampled (by 2) files.
> Close underlay: Close the underlay.
File > Segmentation > Create empty segmentation: Create an empty segmentation with the same
dimension as the underlay.
> Load segmentation…: Load a segmentation from a file.
> Load single class…: Load a segmentation and pick only a single class to add it to the
segmentation. When adding this class to the current segmentation, the user will be
asked to overwrite other classes or not. This operation can be used to merge
segmentation files.
> Show segmentation properties: Show image information of the segmentation.
> Save segmentation…: Save the segmentation under another file name as a .seg file
or .segff file that is a GFF file.
> Save single class…: Save a single class as a segmentation file.
> Close segmentation: Close the segmentation.
File > Overlay > Load overlay…: Load volume from the file as an overlay.
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> Load special: Load overlay using some special methods:
> Create image: Create an overlay. There are several options: sphere, ellipsoid,
cube, cylinder, Menger Sponge, Shepp-Logan phantom.
> Add time points: Load an image file and append it as time point(s). This
operation requires matching 3D/4D dimensions and voxel sizes.
> Add channels: Load an image file and append it as another channel(s). This
operation requires matching dimensions and voxel sizes.
> Open raw file: Open a raw image file and ask the user for the structure.
> Open 2D images as 3D…: load a set of 2D images as one 3D image.
> Open 3D images as 4D…: load a set of 3D images as one 4D image.
> Open sub image…: Load a file but only a rectangular sub-region.
> Open DICOMDIR file…: Open a DICOMDIR file and show a list of images for
selection.
> Open all DICOM files related to file in series…: Open a DICOM file and all
other DICOM files that belong to that file.
> Open single DICOM file from series…: Open a single DICOM file that belong
to that file.
> Load input class as overlay: Create a mask from the input class and load it
as an overlay for volume rendering.
> Show overlay properties: Show image information of the overlay.
> Save overlay as…: Save the overlay as a file. Several file formats are supported. Some file
formats may not support 3D files, resulting in an error message. When selecting PNG, 3D files
are stored as multiple files (only for 8bit PNGs).
> Close overlay: Close the overlay.
File > Overlay for camera > Load overlay for camera…: Load a 2D image shown as an overlay to the
3D rendering.
> Load special: Load overlay using some special methods:
> Add time points: Load an overlay from a file and append it in time to the currently
loaded overlay. This operation requires matching 3D/4D dimensions and voxel sizes.
> Add channels: Load an overlay from the file and add the channels to the current
overlay. This operation requires matching dimensions and voxel sizes.
> Open raw file: Open a raw image file and ask the user for the structure.
> Open DICOMDIR file…: Open a DICOMDIR file and show a list of images for selection.
> Open all DICOM files related to file in series…: Open a DICOM file and all other
DICOM files that belong to that file.
> Open single DICOM file from series…: Open a single DICOM file that belong to that
file.
> Show overlay for camera properties: Show image information of the overlay for the camera.
> Save overlay for camera as…: Save the overlay for camera as a separate file.
> Close camera overlay: Close the camera overlay.
File > Exit: Close the program.
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Table 1: Supported file formats for underlay and overlay files. DICOM files can be converted to NIfTI using Chris
Rorden’s dcm2niigui program (http://people.cas.sc.edu/rorden/mricron/dcm2nii.html).
Name
Analyze
NIfTI
MicroPET
Vevo770
Vevo2100
CT-Imaging
TIFF
MetaImageHeader
PAR/REC
NRRD
PNG
JPEG
Skyscan Recons
VFF files
VOX files
Bitmap files
GFF files
DICOM

Extension
.hdr/.img
.nii
.hdr
.vsi
.bimg,animg,nbimg
.mif,mifx
.tif
.mhd
.par/.rec
.nhdr
.png
.jpg
.log
.vff
.vox
.bmp
.gff
.dcm

Reading is supported
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes (partially)
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes
Yes

Saving is supported
Yes
Yes
No
No
No
No
No
Yes
No
Yes
Yes
No
No
No
No
No
Yes
Yes
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Edit Menu
The edit menu provides operations to edit the underlay or underlay file. It also contains the Undo/Redo
operations, which can be applied to most segmentation and transformation operations.

Edit > Undo (Ctrl + Z): Undo or revert the last action, e.g., segmentation operation. Put the state on a
stack for Redo. Only the last 20 operations are stored in the undo/redo system.
Edit > Redo (Ctrl + Y): Recover the next state from the undo/redo stack.
Edit > Filtering: A sub menu with several filtering operations applied to the selected layer.
Gauss filter: Apply a Gauss filter in X, Y, and Z direction on the selected layer. You can set the
standard deviation (in pixels).
Gauss filter X only: Apply Gauss filter in the X direction on the selected layer.
Gauss filter Y only: Apply Gauss filter in the Y direction on the selected layer.
Gauss filter Z only: Apply Gauss filter in the Z direction on the selected layer.
Median filter (3x3x3): Apply a 3x3x3 median filter on the selected layer.
Gradient magnitude: Computes gradient magnitude for each underlay voxel and loads as
overlay.
Edit > Crop: Crop the underlay with different available modes.
Crop selected layer: Open a dialog to enter a 3D range for cropping. Only the selected layer is
cropped.
Crop to input class: Crop underlay, segmentation, and scribbles to the input class.
Crop to scribbles: Crop underlay, segmentation, and scribbles to the bounding box of the
scribbles.
Crop away zero borders: Crop underlay to remove zero borders away. This operation crops
zero time and channel images. Besides, this operation crops segmentation and scribbles.
Edit > Adjust intensity of input class: Contain operations that can change the voxel intensities.
Set to constant: Set all voxels of the input class to a given value. Work on the selected layer.
Scale by factor: Scale all voxels of the input class by a given factor. Work on the selected layer.

Increase by offset: Increase the voxel intensity of the input class to a given constant. Work on
the selected layer.
Edit > 2D to 3D: Convert a high 2D image into 3D by cutting it into Z pieces. Z is entered by the user.
Edit > 3D to 4D: Convert a long 3D image into 4D by cutting it into T pieces. T is entered by the user.
The T dimension must be a divisor of the Z dimension.
Edit > Transpose: Transpose the data set. Different versions are available, e.g., to swap X and Y axes.
T is the time dimension.
Transpose X and Y: Transpose X and Y axes of the selected layer. If it is the underlay, also apply
to segmentation and scribbles.
Transpose X and Z: Transpose X and Y axes of the selected layer. If it is the underlay, also apply
to segmentation and scribbles.
Transpose Y and Z: Transpose X and Y axes of the selected layer. If it is the underlay, also apply
to segmentation and scribbles.
Transpose X and T: Transpose X and Y axes of the selected layer. If it is the underlay, also apply
to segmentation and scribbles.
Transpose Y and T: Transpose X and Y axes of the selected layer. If it is the underlay, also apply
to segmentation and scribbles.
Transpose Z and T: Transpose X and Y axes of the selected layer. If it is the underlay, also apply
to segmentation and scribbles.
Edit > Flip: Flip the image around an axis (X, Y, or Z).
Flip X: Flip the selected layer in X. If it is the underlay, also apply to segmentation and scribbles.
Flip Y: Flip the selected layer in X. If it is the underlay, also apply to segmentation and scribbles.
Flip Z: Flip the selected layer in X. If it is the underlay, also apply to segmentation and scribbles.
Flip T: Flip the selected layer in T, i.e. reverts the time sequence.
Flip C: Revert the channel sequence in the selected layer.
Edit > Change voxel sizes…: Change the voxel size of the selected layer. Do not resample the image,
but it may appear smaller or bigger.
Edit > Select the next layer (Tab): You can select the next layer, for example, you can switch between
underlay and overlay.

Edit > Resample > Down-sample by 2 (binning): Down-sample the selected layer by 2X2X2, using
averaging (binning) of 8 voxels into one voxel. If it is the underlay, also apply to segmentation and
scribbles.
> Up-sample by 2: Up-sample the selected layer by 2 (in XYZ) using interpolation. If it
is the underlay, also apply to segmentation and scribbles.
> Resample voxel size: Resample the selected layer to user-provided voxel size (in XYZ)
using interpolation. If it is the underlay, also apply to segmentation and scribbles.
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> Resample to viewing rotation: Resample the selected layer to the current viewing
rotation using interpolation. If it is the underlay, also apply to segmentation and
scribbles.
> Resample to viewing rotation (extend): Resample the selected layer to the current
viewing rotation using interpolation. Extend the borders to avoid losing voxel data. If
it is the underlay, also apply to segmentation and scribbles.
> Rotate image around Z: Rotate the selected layer by a user-provided rotation angle
around the Z-axis (counter-clockwise). If it is the underlay, also apply to segmentation
and scribbles.
> Extend image boarders: Extend the boarders of the selected layer with voxels by a
user-provided value. If it is the underlay, also apply to segmentation and scribbles.
> Resample overlay to underlay grid: Resample the overlay to the underlay grid using
interpolation.
> Shift voxels (XYZ): Shift the selected layers’ voxels by a user-provided XYZ-offset.
This operation only acts on the current channel. It can be used to correct the waterfat shift in MR images (if they are split). The voxels at borders are handled by border
extension.
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View Menu
The view menu provides functionality to adjust the viewing settings.

View > Slice views: Toggle the respective slice views on/off in the main window. Up to four different
views can be selected, depending on the type of underlying image data. These are the respective axes
in space (axial, coronal, sagittal) and a 3D overall view.
Show axial view (X,Y): Toggle the axial view on/off.
Show coronal view (X,Z): Toggle the coronal view on/off.
Show sagittal view (Z,Y): Toggle the sagittal view on/off.
Linear interpolation: Toggle the linear interpolation on/off. It is suitable for smoothing edges
(i.e., Anti-aliasing).
Set background color: Set the background color.
Show layer: Toggle showing the selected layer in the 2D views and 3D rendering.
View > Layer settings: The sub menu has items for handling underlay/overlay image.
Layer visibility…> Underlay/Overlay: Toggle the underlay/overlay image on/off.
Show all channels… > Underlay/ Overlay: Toggle the showing all or only the current underlay/
overlay channel on/off. This operation is done in all views.
Select layer color map: Select a predefined color map from a dialog.
Save layer color map: Save the selected layer color map as a PNG file.
View > Windowing settings: Adjust the selected layer windowing. Emphasize areas, e.g., soft tissue or
bone substance, by setting desired value range or threshold for the layer data.
Reset layer windowing (F5): Reset a given layer windowing setting to the maximum range of
the underlying data.
View > Segmentation settings: Show the selected class or all the classes. This operation is done in all
views.
Set segmentation transparency: Set the segmentation transparency for the slice views.
View > Show symbols: Show crosshair, markers, scale bar, etc.
Show viewing center and active point: Toggle showing the viewing center (red
crosshair/sphere) and the active point (green crosshair/sphere) in all 2D and 3D views on/off.
Show markers: Toggle the markers in all 2D and 3D views on/off.

Set marker diameter: Set the diameter of markers [mm].
Show line measurements: Toggle the line measurements on/off.
Show scale bar (in 2D): Toggle the scale bar in all 2D views on/off.
Set scale bar length: Set the scale bar in length [mm].
Show world coordinate system: Toggle showing the world coordinate system in 3D view. X, Y,
and Z-planes are shown in red, green, and blue, respectively.
Show info: Toggle showing information (text) in the 2D slice views.
Show bounding box:
> Show underlay bounding box: Toggle showing a bounding box for the underlay.
> Show overlay bounding box: Toggle showing a bounding box for the overlay.
> Show segmentation bounding box: Toggle showing a bounding box for the
segmentation.
Show color bar: Toggle showing a color bar in 3D and 2D.
View > Viewing transform (2D): This sub menu has items for the 2D viewing transform. The viewing
transform defines the 2D slice views and can be changed interactively with the mouse (ALT+LMB).
Reset 2D viewing transform: If the 2D views have been rotated, enlarged, or reduced, or the
view center was changed, they are reset to their original state.
Reset 2D viewing rotation: If the 2D view has been rotated, it is reset to its original state.
Set viewing zoom: Set the viewing zoom. The desired zoom can be specified in a dialog.
Set view based on start and end markers: Set the view based on the start and end markers.
The 2D views are centered at the start marker position.
Save viewing transform: Save the viewing transform. It covers rotation, zoom, and position of
the 2D views.
Load viewing transform: Load the viewing transform. It covers rotation, zoom, and position of
the 2D views.
Center on brightest pixel: Find the brightest pixel of the selected layer. All views are centered
on this point.
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Options Menu
The options menu provides the following functionality:

Options > Show image information: Show a window with information about the selected layer.
Options > Set menu font size: Set the font size of the menu, e.g., to a larger font.
Options > Set toolbar icon size: Set the icon size of the toolbars, e.g., to a larger font.
Options > Set language…: Change the language of the entire application.
Options > Set language to English: Set the language back to English.
Options > Toggle console: Turn the console window on and off to see extra information.
Options > Set max image size for undo/redo: Set the maximum size in MB for underlay or overlay until
undo/redo works for image operations.
Options > Touch data set: Load (touch) the entire data set into memory. Helpful for some file types
which are loaded on demand by direct memory mapping.

Classes Menu
The classes menu allows the user to add, delete, or rename classes or change their colors.

Classes > Add class: Add a new class with the given name. The color is automatically selected but can be
changed later. The result of the subsequent operation is displayed in the view. Classes with names such as
red, green, blue, or magenta will get the corresponding colors (based on the color list in
https://en.wikipedia.org/wiki/Lists_of_colors).
Classes >

Class visibility…: Toggle the selected class on/off.
Show all classes: Show all defined classes (segmentation). This operation is done in all
views.

Classes > Delete class: Delete the selected class.
Classes > Delete all classes: Delete all classes. The segmentation is cleared.
Classes > Delete unused classes: Delete all classes that are not assigned to an operation in the views.
Classes > Rename class: Rename the selected class with a given name. This operation will not change the
color of the selected class.
Classes > Change class color: Change the color of the selected class.
Classes > Go to class (centroid): Set the view center (the red marker) to the selected class. This operation
is useful to find a small class. However, the voxel with the centroid may have another class, e.g., if the class
has a ring shape.
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Statistics Menu
The statistics menu offers functionality to quantify parameters of the images using the segmentation.

Statistics > Class statistics (selected layer): Compute class (region) statistics for the selected layer (and
the current channel) and show them in a table. When the overlay is selected for quantification, this
can be used to quantify the fluorescence in segmented organs or lesions using µCT-FMT scans.
The following parameters are computed for each class:
•
•
•
•
•
•
•
•

Time Index (only relevant for 4D images)
Time [s] (only relevant for 4D images)
Volume [mm³]
Mean intensity [a.u.] (same unit as the image intensity, typically a concentration unit)
Total (product of volume and mean intensity; if the mean is a concentration, the total value is
an amount)
Stddev (Standard deviation of the intensities of the class)
Min (minimum value of all intensities in the class)
Max (maximum value of all intensities in the class)

The data can be saved in an excel sheet (.csv file) via pressing the button ‘Save to CSV’.
The table can also be saved in the Open Document Format .ods via ‘Save to ODS’. Those files are
automatically readable by Excel and can be imported to different programs as well. Both file formats
also contain temporal information, which is only relevant for 4D images.
Statistics > Slab statistics of input class: Compute statistics of the input class for each z-slice (or thicker
slabs) and store these in an excel sheet.
You can enter a slab thickness, e.g., 10 voxels. Slabs are considered in the Z direction. For each slab,
the volume of the input class is computed and the number of components. Furthermore, you can enter
the histogram borders (e.g., 1.0;2.0;3.0;4.0). Based on the component volume, the components are
sorted into histogram buckets based on the provided histogram borders (e.g., 5 buckets for 4 borders).
The resulting .csv file contains one row for each slab, and the row includes the histogram. The
histograms can be used to analyze blood vessels, e.g., to determine if the number of small or large
blood vessels are increased under some condition.

Statistics > Number of components of input class: Compute the number of separate connected
components of the input class. This operation can be used to count the number of metal fragments,
for example (Gremse et al. 2014).
Statistics > Component statistics of input class: Compute statistics of all separate connected
components of the input class and save these as a .csv file.
The list is sorted by volume (descending). The .csv file contains one row for each component with the
number of voxels, volume, and the XYZ coordinates of the centroid. This operation can be used to
analyze the number and volumes of lung metastases in µCT scans.
Statistics > Centroid of input class: Show the centroid of the input class (mask) in data and world space.
Statistics > Voxel surface area of input class: Compute the surface area of the input class by summing
all the areas of the boundary surfaces of boundary voxels.
Statistics > Principal component direction of input class: Compute the dominant 3D direction of the
input class by computing the dominant eigenvector of the covariance matrix of all segmented voxel
positions.
Statistics > Angle between input and output class: Compute the angle of input and output classes by
computing their principal component directions. It can be used to quantify the angle between two
bones or other classes (Gremse et al. 2014).
Statistics > Histogram of input class (underlay/overlay): Compute a voxel intensity histogram for the
input class of the selected layer. The user provides the range of the histogram and the number of
buckets. The histogram is saved as a .csv file.
Statistics > Line profile (underlay/overlay): Compute a line profile between two user-selected markers
on the selected layer. The line goes through the viewing center (red cross) in the x-direction (data
space).
Statistics > Pair-wise significance matrix: Compute a pairwise significance matrix. This matrix visualizes
the pairwise significances of a multi group test, e.g., one-way-ANOVA with a Tukey post-test. This
feature requires Graphpad Prism to generate a one-way ANOVA with a Tukey post-test. Then, copy the
summary column of the post-test into the clipboard. Then press “Statistics > Pairwise significance
matrix” (see Chapter 4 “Statistics Menu”), which generates an image and places it into the clipboard.
Open MS Powerpoint, for example, and paste the matrix there (Figure 8).

Figure 8: Examples of pairwise significance matrix (PSM).
(A) Each box in the PSM represents the comparison of two
groups. Significant differences (p<0.05) between pairs of
groups are shown in green and insignificant differences in
red. (B) Example of PSM from the publication Al Rawashdeh
et al. 2017. (C) Example of PSM from the publication
Rosenhain et al. 2016.
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Statistics > Dice scores against other segmentation: Compute dice scores of the current segmentation
against another user-provided file.
This operation requires two different segmentations, for example, organ segmentation of the same
data set acquired by two different users. After selecting the menu item, the user needs to select
another segmentation file. Then, the dice score is computed for each class that exists in both
segmentations. The dice score represents the similarity, e.g., 1.0 means perfect match and 0.0 means
no overlap at all. An excel (.csv) file is generated, which contains all dice scores for these
segmentations.
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Segmentation Menu
This segmentation menu provides functionality to alter the segmentation. The operations may use
input and output classes.

Segmentation > Morphologic: Applies different morphologic operations on the input class. These are
implemented using a distance map. The extent of the operation is defined by a user-selected value.
Dilate: Dilates the input class by width in voxels. It makes a class “thicker” by extending the
class to the outside.
Erode: Erodes the input class by several voxels. It shrinks a class from the borders. The removed
voxels are put into the output class. This operation can be used to segment a region into “onion
peelings”, e.g., the rim and core of a tumor.
Open: Performs a morphologic opening on the input class, i.e., erode and dilate. This operation
removes small islets.
Close: Performs a morphologic closing on the input class, i.e., erode and dilate. This operation
closes small holes in the input class.
Coat: Places a coating around the input class. The coating is assigned to the output class.
Segmentation > Thresholding: Provides different threshold operations for segmentation. These may
depend on one or two user-provided thresholds. The thresholding operations make use of the selected
layer voxel intensities.
Above: Assigns all input class voxels above or equal to a threshold to the output class on the
selected layer.
Below: Assigns all input class voxels below or equal to a threshold to the output class on the
selected layer.
Range: Assigns all input class voxels in an intensity range to the output class on the selected
layer.
Above center: Assigns all input class voxels above the windowing center to the output class on
the selected layer.
Local > Above: Applies a local thresholding to the input class voxels on the selected layer.

Compute a Gaussian-smoothed image based on user-provided stddev (in voxels). Then assigns
all voxels with image intensity above Gaussian-image intensity plus threshold to the output
class. A higher threshold results in fewer new voxels.
Local > Below: Applies a local thresholding to the input class voxels on the selected layer.
Compute a Gaussian-smoothed image based on user-provided stddev (in voxels). Then assigns
all voxels with image intensity below Gaussian-image intensity plus threshold to the output
class. The threshold can be negative. A lower threshold results in fewer new voxels.
Segmentation > Smooth input class: Smooths the input class. This operation is implemented using a
Gaussian filter with a standard deviation of 2 (voxels) and subsequent thresholding.
Segmentation > Assign class: Assigns all voxels to the (nearest) output class or swaps voxels of input
and output class.
Assign input to output class: Assigns all voxels of the input class to the output class.
Assign input class voxels to nearest other class: Assigns all voxels of the input class to the
nearest output class.
Swap voxels of input and output class content: Swaps all voxels of the input and output class.
Segmentation > Clear segmentation: Clears the segmentation but keep the (empty) classes. It changes
all voxels to the class “unclassified” with keeping the name of all classes.
Segmentation > Fill region: Provides several region filling (or region growing) operations. These are
seed point-based operations, i.e., starting at a seed point (the active point is set by a right-click). Then
they fill the six-connected region with the output class.
Fill region unlimited: Finds the connected component starting from the active points (seed
point) and assign it to the output class.
Fill region volume bounded: Performs fill region but stop at a certain volume.
Fill region distance bounded: Performs fill region but stop at a certain path distance.
Grow into output class: Grows the input class into the output class by one voxel.
Keep this component (despeckle): Assign all components except the one with the active point
to the output class.
Segmentation > Find components: Finds connected components of the input class and assign these to
the output class.
Find small components: Puts all connected components of the input class below a userprovided size into the output class.
Find large components: Puts all connected components of the input class above a userprovided size into the output class.
Find largest component: Puts the largest connected component of the input class into the
output class.
Find enclosed by: Finds all connected components of the input class enclosed by a userprovided class and assign these to the output class. The user can provide a minimal enclosing
ratio (between 0 and 1). This operation is useful for components connected to the outside,
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e.g., the trachea, which never reach 1 because the border-surface is added to the denominator
only.

Segmentation > Resample segmentation to selected layer: Resample the current segmentation to the
grid of the selected layer.
Segmentation > Transfer segmentation to overlay: Transfers the current segmentation to the overlay
grid and save it to a file.
Segmentation > Change voxel size: Change voxel size of the segmentation.
Segmentation > Clipboard: Copy or paste classes to/ from the clipboard.
Copy class to clipboard (Ctrl+C): Copy class to the clipboard.
Paste class from clipboard (Ctrl+C): Paste class from the clipboard.
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Math Menu
This math menu provides functionality to apply mathematical functions on the voxels of the selected
layer. The operations are performed in memory and do not affect the selected image file that has been
opened to load the underlay or overlay.

Math > Voxel-wise operation: Perform the same operation to each voxel.
Add constant: Add a user-provided constant value to each voxel.
Scale voxels: Multiply voxels by a user-provided factor.
Divide voxels: Divide voxels by a user-provided value.
Transform voxels: Apply a linear transform y=mx+c to each voxel with user-provided scale and
offset.
Square voxels: Square each voxel.
Log Voxels: Logarithm of each voxel. The voxel type is converted into float.
Exp voxels: Exponentiate each voxel to the power of e. The voxel type is converted into float.
Abs voxels: Absolute each voxel, i.e., the sign is removed.
Sigmoid voxels: Apply the sigmoid function to each voxel. The voxel type is converted into
float.
Invert voxels: Replace each voxel value with 1/value. Zero values are not changed. The voxel
type is converted into float.
Clamp negative voxels: Set negative voxels to 0.
Convert voxel type: Convert each voxel type to a user-provided type, e.g., float or int16. Values
outside the range are clamped, e.g., 1230 becomes 255 when converting to uchar which has a
range [0,255].
Swap Endianness of voxels: Convert voxel value from little endian to big endian and vice versa.
Some Linux systems provide big endian voxels.
Zero noisy bits: Remove the lowest bits of the mantissa (setting to 0). Make noisy images
compressible.
Math > Combine underlay and overlay: Operate on the overlay and underlay. This operation requires
that overlay and underlay have equal sizes.
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Add overlay on underlay: Add each overlay voxel to the underlay voxel.
Subtract overlay from underlay: Subtract each overlay voxel from the underlay voxel.
Multiply underlay by overlay: Multiply each underlay voxel by the overlay voxel.
Divide underlay by overlay: Divide each underlay voxel by the overlay voxel (only for non-zero
overlay voxels).
Math > HU calibration: Perform HU calibration on the underlay. It requires Air and Water classes with
nonzero sizes. The function computes the mean intensity of Air and Water and applies scale and offset
so that Air has intensity -1000 and Water has intensity 0.
Math > Add noise: Add random uniform noise in user-provided range ([-range, range]) to each voxel.
Math > Compute feature maps: Several feature maps can be generated from the underlay and are
automatically displayed as an overlay in all opened views.
Local mean: Compute the local mean (Gauss filter) of the underlay and load the map as an
overlay.
Local stddev: Compute the local stddev (Gauss filter) of the underlay and load the map as an
overlay.
Local smoothness: Compute the local smoothness (inverse of local stddev) of the underlay and
load the map as an overlay.
Gradient magnitude: Compute the Gradient magnitude of each underlay voxel and load the
map as an overlay.
Compactness of components of input class: Compute the sphericity of each connected
component and load the map as an overlay. This operation allows selecting components based
on their shape using thresholding.
Distance map inside input class: Compute a distance map and loads it as overlay. The distance
map contains the distances to the nearest voxel inside the input class.
Distance map outside input class: Compute a distance map and loads it as overlay. The
distance map contains the distances to the nearest voxel outside the input class.
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Channels Menu
The channels menu provides functionality for 5D data sets, whereby the fifth dimension represents
the channels.

Channels > Show all channels > Show all underlay: All channels or only the current underlay channel
are shown. This operation is done in all views.
Channels > Show all channels > Show all overlay: All channels or only the current overlay channel are
shown. This operation is done in all views.
Channels > Show all channels > Show all overlay cam: All channels or only the current overlay cam are
shown. This operation is done in all views.
Channels > Average all channels: Average all channels of the selected layer.
Channels > Delete current channel: Delete the current channel.
Channels > Extract channels: Extract a user-provided list of channel indices from the selected layer.
This operation can also be used to reorder channels.
Channels > Delete channels after current: Delete all channels of the selected layer after the currently
selected channel.
Channels > Set channel information: Set name, width (duration), unit, and center value of the current
channel of the selected layer.
Channels > Previous channel: Go to the previous channel of the selected layer.
Channels > Next channel: Go to the next channel of the selected layer.

Scribble Menu
The scribble menu provides functionality related to the “scribbles”. Scribbles are drawn by the user
into the slice views to delineate regions. They appear as green voxels. Each voxel of the underlay can
be marked, i.e., the scribbles are stored as a data set of the same X, Y, and Z dimensions as the
underlay. The scribbles are temporary and do not directly affect the segmentation upon being drawn.

Scribble > Clear scribbles (F1): Delete all scribbles and the red shadow. This operation should be
pressed before delineating a region to delete some old scribbles that may exist in other slices.
Scribble > Quick cut (F2): Fill the scribbles with a convex hull and delete the input class covered by that
region.
Scribble > Segment foreground (F3): Segment foreground and show it as a red shadow. This operation
uses all available information, i.e., foreground/background scribbles and (optionally) the voxel
intensities.
Scribble > Accept red shadow as output class (F4): Turn the red shadow into the output class.
Scribble > Accept red shadow as output class restricted to input class: Turn the red shadow into the
output class but restrict it to the input class.
Scribble > Show bounding box: Set the red shadow to the bounding box of the foreground scribbles.
Scribble > Crop to scribbles: Crop the underlay to the bounding box of the foreground scribbles. (a
good operation to reduce image file size).
Scribble > Dilate scribbles to output class: Dilate the scribbles into the output class by a user-provided
thickness [mm].
Scribble > Delete background scribbles: Delete only the background scribbles (dark green).
Scribble > Save scribbles: Save scribbles to a file.
Scribble > Load scribbles: Load scribbles from a file.
Scribble > Stroke type: This submenu has items for different stroke types, e.g., draw
foreground/background scribbles, delete scribbles.

Foreground: Draw only foreground scribbles in 2D views.
Background: Draw only background scribbles in 2D views.
Both (default): Draw foreground and background scribbles at the same time.
Delete: Delete all foreground/background scribbles within the user-drawn area.
Scribble > Drawing type: This submenu has items for different drawing types, i.e., only the drawn lines
or the area within the drawn lines are defined as scribbles.
Lines: Draw individual lines. Only the drawn lines are selected as scribbles.
Filled (default): Draw a surface bounded by a polygon. The polygon within the drawn lines (not
including the lines) is selected as scribbles.

Figure 9: Segment the spleen using scribble operations. (A) Draw scribbles using intensities in the 2D slice
views. You slice through the 2D slices and draw scribbles (Foreground: green; Background: dark green) in
different 2D slices. (B) Connect the foreground scribbles as the red mask by using the “Segment foreground”
operation (F3). To make sure that the spleen is totally included within the red mask, you need to repeat
these two steps “Draw scribbles” and “Segment foreground”. (C) Add a new class “Spleen” and then, put it as
the output class (F4). (D) Accept the red mask as the output class. You can use the “Context menu” (rightclick in any slice), e.g., “Smooth class”, “Morphologic > Close”, to make the spleen segmentation smooth and
complete.
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Batch Menu
The batch menu provides functionality to work on multiple data sets. They need to be stored in parallel
folders. These data sets can represent multiple samples (bones, organs, mice, for example), or multiple
time points of the same mouse, as for longitudinal imaging scans. The batch features are very useful
for quickly getting an overview of such files and creating consistent images of multiple subjects, i.e.,
under the same windowing settings.

Batch > Set batch settings: Set the study folder of the current underlay folder as a parent/ batch folder.

The settings of the current underlay folder including the windowing settings, color tables, and
the 3D camera position are captured and applied to subfolders within the parent folder. These
subfolders are listed parallel, and the user can navigate through them (F10, F11), see Figure 10.
Thereby, you can directly compare the data sets with each other (such as different animals in
a longitudinal imaging study). Batch statistics can be applied to a certain segmentation within
the subfolders.
Figure 10: Batch modus correct.
The folder: study1 contains subfolders of different mice and time
points (A). For all samples, the
underlay, overlay, and two
segmentations (Tumor.segff and
Organ.segff) were stored in the
respective folder (B). You can
open a segmentation, e.g.,
Organ.segff of M01_t123 (red
asterisk) and perform the
operation: >Set batch settings< to
get a list of all organ
segmentations of all animals and
time points. Batch statistics will
be performed on all segmented
organs. To analyze only the
tumor, you must load Tumor.segff
and perform the operation >Set
batch settings< again. Using F10
and F11, you can go to the next/
previous data set.
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Figure 11: Batch modus incorrect. In some cases, the batch modus might not work properly. Some common
mistakes are displayed in this figure. If you load data of a different parent folder, for example mouse1 of
study 2 (red asterisk), you cannot apply the batch modus to the subfolders of study1 even the files have the
same name; they need to be stored in the same parent underlay folder. The folder M1_t4 will be loaded but
will appear at the end of the batch list: make sure to correctly name your folders (M01_t4 instead of M1_t4).
The segmentations of M02_t00h will not appear in the tumor or organ batch list due to spelling errors
(Tumour.segff and Organ.sgeff). Also, no data will appear for M02_t24h, because the user forgot to analyze
this sample and no segmentation files are available in the subfolder at all.

Batch > Show batch setting: Show the current batch settings and the format of the selected subjects.
Batch > Load first subject: This operation loads underlay, overlay, and existing segmentations of the
first subject and sets windowing and camera settings accordingly to the batch settings.
Batch > Load previous subject (F10): This operation loads underlay, overlay, and existing
segmentations of the previous subject and sets windowing and camera settings accordingly to the
batch settings.
Batch > Load selected subject: This operation loads underlay, overlay, and existing segmentations of
a subjected selected by the user and sets windowing and camera settings accordingly to the batch
settings.
Batch > Load next subject (F11): This operation loads underlay, overlay, and existing segmentations of
the next subject and sets windowing and camera settings accordingly to the batch settings.
Batch > Load last subject: This operation loads underlay, overlay, and existing segmentations of the
last subject and sets windowing and camera settings accordingly to the batch settings.
Batch > Batch class statistics (underlay): Compute the class statistics of the selected layer for all
subjects. Save results into one .csv file. This operation can save a lot of effort, because the same
statistics often need to be computed for many scans and merged into one .csv file.
Batch > Batch class statistics (overlay): Compute the class statistics of the selected layer for all
subjects. Save results into one .csv file. This operation can save a lot of effort, because the same
statistics often need to be computed for many scans and merged into one .csv file.
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3D-Rendering Menu
The rendering menu allows the user to configure the 3D rendering.

Rendering > Underlay: Different rendering modes for the underlay can be toggled by the user. Iso
stands for iso-surface and MIP for maximum intensity projection.
Iso rendering: Render layer as Iso surfaces using the venter value of the windowing settings.
This operation is useful to find a threshold.
MIP rendering: Render layer as MIP (maximum intensity projection). For each pixel, the
maximum voxel value is shown.
Volume rendering: Render layer by volume rendering using the current color table.
Rendering > Overlay: Different rendering modes for the overlay can be toggled by the user. Iso stands
for iso-surface and MIP for maximum intensity projection.
Iso rendering: Render layer as Iso surfaces using the venter value of the windowing settings.
This operation is useful to find a threshold.
MIP rendering: Render layer as MIP (maximum intensity projection). For each pixel, the
maximum voxel value is shown.
Volume rendering: Render layer by volume rendering using the current color table.
Rendering > Overlay for camera > Set scale factor: Set the scale factor for the camera overlay
rendering.
Rendering > GPU rendering: Activate using the GPU rendering (recommended). Without GPU, the
rendering will be very slow.
Rendering > CPU volume rendering: Activate using the CPU for colume rendering (recommended).
Without CPU, the rendering will be very slow.
Rendering > Anti-aliasing: Activate anti-aliasing, i.e., rendering 4 sub-pixels per pixels to average them.
This operation makes the image smooth. Toggling the anti-aliasing on will make 3D rendering a bit
slower.
Rendering > Set background color: Set the background color (e.g., white) for 3D rendering. The
default is black.
Rendering > Set camera angles: Set X and Y camera angles. This operation allows the user to change
the camera angle in the horizontal direction. Default is 10°. The total angle is twice this value. The
camera angle in the vertical direction depends on the size of the panel.

Unmixing Menu
The unmixing menu enables to perform spectral unmixing. It requires multi-channel data sets, i.e., at
least two channels. Unmixing involves several steps. First, the pure spectra need to be determined and
quantified by selecting regions with the pure signal of the classes. Then, the spectral unmixing
operation separates each voxel based on its own spectrum into the different components. Further
information can be found in the white paper “Spectral unmixing (multispectral images) with Imalytics
Preclinical”.

Unmixing > Save class spectra: Compute the mean intensity of each class in each channel for the
selected layer. This operation requires a segmentation with at least two classes. The result is saved as
a spectra file, which can be opened with a text editor.
Unmixing > Spectral unmixing: Unmix the spectra, i.e., compute the intensities for the classes for each
voxel for the selected layer. This operation requires a multichannel image (for the selected layer) and
asks the user to load a spectra file (see above). The computation searches for nonnegative values for
each class such that the predicted mixed image (using the spectra) resembles the measurements. The
resulting multi-channel image (one channel per class) is loaded as overlay and stored to disk.
Unmixing > Generate example underlay (1 class and background): Generate an example underlay
including 1 class and background.
Unmixing > Generate example underlay (2 classes and background): Generate an example underlay
with 2 classes and background.
Unmixing > Set number of iterations: Set the number of iterations to a user-provided number. More
iterations may increase the accuracy at the expense of computation time.

Fusion Menu
The fusion menu provides operations for fusing or aligning the underlay and overlay. Both the underlay
and overlay have a transformation (rotation and translation) to go between “data” and “world”
coordinate systems. These transformations can be adjusted until the underlay and overlay are aligned.
This menu requires a special license.

Fusion > Underlay transformation: Perform layer transform to the identity transform on the underlay.
> Reset transform: Reset the layer transform to the identity transform.
> Set translation: Set the translation based on the user-provided X/Y/Z translation
values. This operation can be used to correct a shift in the fusion between the underlay
and overlay.
> Set rotation: Set the rotation based on the user-provided X/Y/Z rotation angles. The
rotation is performed around the origin.
> Flip transform > X/Y/Z-Dimension: Flip in X, Y, or Z-direction to the underlay. This
operation can be used to generate a mirrored rendering of the layer.
> Save transform…: Save the transformation as a text file.
> Load transform…: Load the transformation from a text file.
> Load and apply transform: Load and apply a new transformation for the underlay,
including the old transformation.
Fusion > Overlay transformation: Perform layer transform to the identity transform on the overlay.
> Reset transform: Reset the layer transform to the identity transform.
> Set translation: Set the translation based on the user-provided X/Y/Z translation
values. This operation can be used to correct a shift in the fusion between the underlay
and overlay.
> Set rotation: Set the rotation based on the user-provided X/Y/Z rotation angles. The
rotation is performed around the origin.
> Flip transform > X/Y/Z-Dimension: Flip in X, Y, or Z-direction to the underlay. This
operation can be used to generate a mirrored rendering of the layer.
> Save transform…: Save the transformation as an .affine file.
> Load transform…: Load the transformation from an .affine file.
> Load and apply transform: Load and apply a new transformation for the overlay,
including the old transformation.
Fusion > Segmentation transformation: Perform layer transform to the identity transform on the
segmentation.
> Reset transform: Reset the layer transform to the identity transform.
> Set translation: Ask for 3 values to update the translation.
> Set rotation: Ask for 3 angles (X/Y/Z) to update the segmentation rotation. The
rotation is performed around the original segmentation.
> Save transform…: Save the transformation as an. affine file.
> Load transform…: Load the transformation from an. affine file.
Fusion > Center overlay on underlay: Set the overlay transform so that the overlay is centered on top
of the underlay.
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Figure 12: Marker-based fusion. The underlay is a µCT scan (white skeleton) and the overlay is an artificial
data set with blurry signals in the bones (NIH coloured). (A) Three markers are placed in the underlay (3D
view) at the two elbows and one knee using Mouse mode toolbar > Create marker. (B) After selecting the
overlay, three markers with identical names are placed at the corresponding positions in the overlay (3D
view). (C) After clicking Fusion > Register overlay to underlay (markers) > Compute rotation and translation,
the overlay transformation is adjusted, and the overlay appears properly aligned to the underlay. At least
three markers are required for the image fusion. The markers should not be positioned on a line on the 3D
view of the underlay and overlay.

Fusion > Stitch overlay on underlay: Stitches the overlay to the underlay. Extends the underlay to covr
both.
Fusion > Register overlay to underlay: This sub menu has items for the layer transform computation
between the underlay and overlay.
> Show residual score (markers): Compute a residual score based on the markers’
positions to warp the underlay markers onto the overlay markers (not apply it for the
overlay).
> Compute rotation and translation (markers): Set the overlay transform to minimize
the residual between the corresponding underlay and overlay markers (see Figure 12).
This operation requires at least three markers in the underlay and overlay with
identical names. Marker placement is explained in the “Markers Menu”.
> Compute rotation and translation (image-based, coarse): Compute the overlay
transform so that the image difference (mean squared voxel differences) between the
underlay and transformed overlay, restricted to the input class, is minimized. The
computation is performed on down-sampled images, and several initial
transformations are used. The next menu item can be called to compute a more
accurate transformation if the result looks ok. If a good result is not found, you can try
it again.
> Compute rotation and translation (image-based, fine): Similar to the menu item
above (coarse fusion). However, the overlay transformation is computed at a higher
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resolution if GPU memory allows. Large data sets (above 2 GB) are down-sampled
anyways.
> Show residual score (image-based): Show the residual error, i.e., the cost term
minimized in the above image-based registration methods.
> Replace overlay with squared registration residual (image-based): The overlay is
swapped with a feature map of the residual computed above.

Figure 13: Bone defect size assessed using the fusion module. (A) The CT scan after surgery for harvesting
bone material is loaded as the underlay. A defect is visible in the left hip bone (red arrow). (B) The left hip is
segmented using thresholding, cutting, and region growing and shown as a dilated segmentation. (C) The
scan before surgery is loaded as the overlay and appears misaligned to the underlay. (D) The fusion module
is used to align the overlay to the underlay. The alignment is computed based on the segmented and dilated
left hip. The legs appear misaligned after a fusion because they are in different positions in the two scans. (E)
The missing piece of bone can be segmented based on thresholding and subtracting the left hip
segmentation on the underlay.

Fusion > Register camera overlay to underlay: This sub menu has item for the layer transform
computation between the underlay and overlay.
> Compute camera position (markers): Computes the camera position so that the
projected underlay markers are close to the camera overlay markers.
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Nuclear Menu
This nuclear menu is useful to calibrate standardized uptake value (SUV) and %ID/g of PET and SPECT
image data sets.

Nuclear > SUV calibration: Apply SUV calibration to the current channel of the selected layer, using a
voxel scale factor based on user-provided weight [g] and injected dose [MBq]. It requires voxels in
Bq/ml, kBq/ml, or MBq/ml. Voxel unit will be changed to SUV. Color table min/max are adjusted by
the voxel scale factor.
Nuclear > %ID/g calibration: Apply %ID/g calibration to the current channel of the selected layer, using
a voxel scale factor based on injected dose [MBq]. It requires voxels in Bq/ml, kBq/ml, or MBq/ml.
Voxel unit will be changed to SUV. Color table min/max are adjusted by the voxel scale factor.
Both functions can correct the measurement for delay, which requires the injection time and the exact
scan start time.
Nuclear > Convert %ID/g to SUV: Converts voxel from %ID/g to SUV using the scale factor weight/100.
Asks for the subject weight. Color table min/ max values are adjusted by the voxel scale factor.
Nuclear > Convert SUV to %ID/g: Converts voxel from %ID/g to SUV using the scale factor 100/ weight.
Asks for the subject weight. Color table min/ max values are adjusted by the voxel scale factor.
Nuclear > Segment SPECT phantom: Segment the SPECT phantom, see Figure 14 (first described by
Visser et al. 2010). The software asks the user for a reference segmentation. After choosing one, all
relevant parts of the phantom will be segmented.

Figure 14: Schematic overview of the SPECT phantom (modified after Visser et al.)(A). µCT scans of the SPECT
phantom in 3D (B) and the axial views of the rods (C) and the water and air compartments (D).

Bioluminescence Menu
The bioluminescence menu provides functionality for bioluminescence images.
For further detailed information, read the White Paper about “BLI-CT analysis using Imalytics
Preclinical” (Menu > Help > Tutorials > Optical > BLI-CT > Show White Paper).

Bioluminescence > Remove hot spots: Remove hot spots from the selected layer. Hot spots are
identified in x-y-slices as pixels that are brighter than most of their 8 neighbors.
Bioluminescence > Barrel correction: Correct the barrel distortion of the selected layer to each x-yslice. This operation is also called rectification. The image is transformed by moving the pixels outward
by the factor 1/(1+alpha*r²) where r is the distance of the pixel to the center and alpha is a cameradependent coefficient (e.g., 0.00000025).
Bioluminescence > Vignetting correction: Correct the vignetting of the underlay to each x-y-slice. This
is also called homogeneity correction. It is assumed that the vignetting applies a factor 1-alpha*r²
where r is the pixel's distance to the center. The correction applies the inverse. Alpha is a cameradependent coefficient that also depends on the aperture.
Bioluminescence > Create example image: Generate an example image (1024x1024 pixels) showing a
checkerboard with barrel distortion and vignetting (Figure 15A). The generated image with darker
edges and barrel distortion can be corrected using Bioluminescence > Vignetting correction (Figure
15B) and Bioluminescence > Barrel correction (Figure 15C) with the default values.

Figure 15: Vignetting and barrel correction. (A) Barrel-distorted image with darker edges due to the
vignetting effect. (B) Vignetting-corrected image. (C) Barrel-corrected image after the vignetting correction to
the original image.

Bioluminescence > Open Ivis data: Read Ivis image data, i.e., a folder with excitation and emission
images. The user needs to select a file named AnalyzedClickInfo.txt. The excitation image is loaded as
the underlay and the fluorescence image as the overlay. Both images are corrected for exposure time.

Kinetics Menu
This kinetics menu provides functionality for Pharmacokinetics.

Kinetics > Counts to Becquerel:
Kinetics > Estimate parameters for input class (OneTCIrr): One tissue compartment irreversible
Kinetics > Estimate parameters maps (OneTCIrr): One tissue compartment irreversible
Kinetics > Estimate parameters for input class (OneTCAsy): One tissue compartment asymmetrical
Kinetics > Estimate parameters maps (OneTCAsy): One tissue compartment asymmetrical
Kinetics > Estimate parameters for input class (TwoTCSymIrr): Two tissue compartment symmetrical
and irreversible
Kinetics > Estimate parameters maps (TwoTCSymIrr): Two tissue compartment symmetrical and
irreversible
Kinetics > Estimate parameters for input class (TwoTCAsyIrr): Two tissue compartment asymmetrical
and irreversible
Kinetics > Estimate parameters maps (TwoTCAsyIrr): Two tissue compartment asymmetrical and
irreversible
Kinetics > Estimate parameters for input class (TwoTCSymAsy4kc): Two tissue compartment
symmetrical and asymmetrical, constant K4
Kinetics > Estimate parameters maps (TwoTCSymAsy4kc): Two tissue compartment symmetrical and
asymmetrical, constant K4
Kinetics > Estimate parameters for input class (TwoTCAsyAsy4kc): Two tissue compartment
asymmetrical and asymmetrical, constant K4
Kinetics > Estimate parameters maps (TwoTCAsyAsy4kc): Two tissue compartment asymmetrical and
asymmetrical, constant K4
Kinetics > Estimate parameters for input class (TwoTCAsyAsy): Two tissue compartment asymmetrical
and asymmetrical
Kinetics > Estimate parameters maps (TwoTCAsyAsy): Two tissue compartment asymmetrical and
asymmetrical

Relaxometry Menu
This relaxometry menu provides functionality for MRI relaxometry. It requires a 4D data set, i.e., 3D
images at multiple time points (e.g., echo times). Relaxometry works by curve fitting, i.e., a
parameterized curve is fitted to a measurement vector, and the parameters are found by a cost
function consisting of the residual sum of squares. During fitting, a small magnitude penalty
(0.001*measurements²*R², R is the residual sum of squares) is added to the cost term to make the
solution more stable.

In the relaxometry curve fitting, the voxel-based fitting is restricted to the input class voxels, which is
helpful to avoid spurious values in the air (where we have only noise). Therefore, the user can first
segment the air and then perform the fitting on the non-air voxels.

Figure 16: T1 relaxometry curve fitting. The blue curve shows the measured intensities. The fit consists of
two parts: 1) the grey part stands for the simple exponential fit; 2) the orange part stands for the absolute
value of the negative part of the grey exponential fit at the early echo times.

Relaxometry > T1 voxel-wise: Compute 𝑅1 for each voxel of the input class. Fit an exponential curve
𝑓(𝑡) = 𝑠 × |1 − 𝑐𝑒 −𝑅1×𝑡 | to each voxel of the selected layer. The constant 𝑐 (2 for inversion recovery
and 1 for saturation recovery) is provided by the user. For fitting the T1 relaxometry curve, the least
residual sum of squares is minimized. The fitting requires that the time intervals of the 4D data set are
properly set (see menu “Time”). Thus, the scale 𝑠 and 𝑅1 can be fitted. The resulting parameter R1
map, i.e., one value for each voxel, is loaded as the overlay. Figure 16 shows the typical intensity and
a fitted curve.

Relaxometry > T1 class-based (input-class): Compute 𝑅1 for the input class. Fit an exponential curve
𝑓(𝑡) = 𝑠 × |1 − 𝑐𝑒 −𝑅1×𝑡 | to the input class values in the underlay. The parameter computation 𝑅1 is
similar to the above “Relaxometry > T1 voxel-wise”. But the fitting of this operation is performed only
for the mean values of the input class and not for each voxel. Therefore, the result is not a voxel map.
The result is stored as a .csv file which can be opened with Excel.

Figure 17: T2 relaxometry curve fitting. The blue curve shows the measured intensities. Due to measurement
noise, there is a nonzero tail at later echo times. The simple exponential fit is shown in orange, but it cannot
properly model the nonzero values at later echo times. An improved exponential fit with an offset is shown
in gray.

Relaxometry > T2 voxel-wise: Compute 𝑅2 for each voxel of the input class. Fit an exponential curve
𝑓(𝑡) = 𝑠 × 𝑒 −𝑅2×𝑡 to each voxel of the selected layer. The scale 𝑠 and 𝑅2 are fitted. The resulting 𝑅2
map, i.e., one value for each voxel, is loaded as an overlay. Figure 17 shows the typical intensity and a
fitted curve.
Relaxometry > T2 voxel-wise with offset: Compute 𝑅2 for each voxel of the input class. Fit an
exponential curve 𝑓(𝑡) = 𝑠 × 𝑒 −𝑅2×𝑡 + offset to each voxel of the selected layer. The resulting 𝑅2
map, i.e., one value for each voxel, is loaded as an underlay. The offset is important for high 𝑅2 values
(http://www.ncbi.nlm.nih.gov/pubmed/23359410). Figure 17 shows the typical intensity and a fitted
curve with an offset correction.
Relaxometry > T2 class-based (input-class): Compute 𝑅2 for the input class based on the underlay.
The parameter computation 𝑅1 is like the above “Relaxometry > T2 voxel-wise” (with or without
offset). But the fitting of this operation is performed only on the mean values of the input class and
not for each voxel. Therefore, the result is not a voxel map. The result is saved as a .csv file which can
be opened with Excel.
Relaxometry > Set regularization strength: Set the regularization strength (magnitude penalty). A
higher value results in smoother results and avoids extreme results. All fitting methods described
above apply a magnitude penalty to the 𝑅1 or 𝑅2 parameter to avoid strange values for degenerate
cases.
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Vascular Menu
The vascular menu provides functionality to analyze blood vessels.

Vascular > Set start point: Set a marker (see “Markers Menu”) at the active point (right mouse click
position) with the name “Start”.
Vascular > Set end point: Set a marker (see “Markers Menu”) with the name “End”.
Vascular > Elastic sphere diameters: Compute the blood vessel diameters (Figure 18) through a
segmented blood vessel. This operation requires the start and end markers. An elastic sphere is placed
in the vessel's center through a segmented blood vessel from the start to the end markers. Thus, the
blood vessel diameters can be computed. The diameter result can be saved as an excel sheet. This
process is computationally expensive for large data sets and long paths.

Figure 18: Blood vessel diameter measurements. A segmentation of blood vessels is required. Then, the start
(purple) and end (blue) points need to be set. The start and end markers can be placed in the vessel's center
using the 3D view but better using a 2D slice view. The vessel diameters can be computed using Vascular >
Elastic sphere diameters. The results are saved to a spreadsheet file.

Vascular > Path tortuosity: Compute the shortest path between the start and end markers. This
operation also computes the line distance. The ratio is the path tortuosity, i.e., tortuous paths will
result in a larger score.
Vascular > Distance map inside input class: Compute a distance map (Gremse et al. 2011a) and load
it overlay. This distance map contains the distances to the nearest voxel inside the input class.
Vascular > Distance map outside input class: Compute a distance map (Gremse et al. 2011a) and load
it overlay. This distance map contains the distances to the nearest voxel outside of the input class.

Vascular > Create vascular example image: Create a simple vascular example image and load it
underlay.
Vascular > Vesselness: Compute the vesselness score for each voxel of the input class (which
represents the vessels). The output class mask is used as an image surrounding the vessels. The score
map is loaded as the overlay

Bone Menu
The bone menu allows to characterize bone structures. The bone statistics are provided in cm (or cm²,
cm³, etc.) and not in mm to meet widespread conventions. Most of the operations in this menu require
an input class (can be unclassified) and a threshold. Furthermore, many parameters (e.g., the bone
volume) are computed by oversampling the data set (with linear interpolation) to improve the
accuracy.

Bone > Create test data: Create 3D image data (sphere, multiple spheres, rods, or plates) with defined
bone parameters. After successfully creating a test image, the bone parameters (e.g., BV, TV) are
shown in an appearing window.
Create test data (sphere): Create a 3D image containing a sphere shape with defined bone
parameters. It shows the bone statistics of the sphere.
Create test data (multiple spheres): Create a 3D containing multiple spheres with defined
bone parameters. The number of spheres per row is provided by the user. It shows the bone
statistics of the spheres.
Create test data (rods): Create a 3D containing multiple rods. The number of rods per row is
provided by the user. It shows the bone statistics of the rods.
Create test data (plates): Create a 3D containing multiple plates. The number of plates per row
is provided by the user. It shows the bone statistics of the plates.
Bone > Bone volume (BV) of input class: Compute the bone volume [cm³], i.e., the volume of the
region inside the input class which has an intensity greater or equal to the threshold.
Bone > Total volume (TV) of input class: Compute the total volume [cm³] of the input class.
Bone > Bone volume fraction (BV/TV) of input class: Compute the ratio of the bone volume and total
volume of the input class.
Bone > Bone surface (BS) of input class: Compute the bone surface area of the region with intensity
higher than the threshold in the input class.
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Bone > Bone-specific surface (BS/BV) of input class: Compute the ratio of the bone surface and bone
volume.
Bone > Bone mineral density (BMD) of input class: Compute the mean bone mineral density of the
input class. The unit is the same as the unit of the voxels. To achieve the unit [g/cm³], the user needs
to calibrate the intensities first.
Bone > Trabecular thickness (Tb.Th) of input class: Compute the mean distance [cm] of the bone (i.e.,
the region higher than the threshold) to the outside of the bone. This is performed using a distance
map. The operation is restricted to the input class.
Bone > Trabecular separation (Tb.Sp) of input class: Compute the mean distance of the non-bone (i.e.,
the region lower than the threshold) to the inside of the bone. This is performed using a distance map.
The operation is restricted to the input class.
Bone > Set crop extension: Set a crop extension distance for the computations in voxels using a userprovided value. This operation extends the bounding box around the input class and affects the
resulting value. The value should be like the structural size, e.g., the trabecular separation.
Bone > Bone statistics: Compute the above-mentioned parameters for the input class “bone” and save
the result as a .csv file.
Bone > Batch bone statistics: Compute all above-mentioned parameters for the input class and save
the result as a .csv file. Before applying this operation, please set batch information with the project
by pressing Menu > Batch > Set batch setting (see also the Batch Menu).
Bone > Local thickness map (Tb.Th) of input class: Compute the local thickness map and show it as an
overlay.
Bone > Local separation map (Tb.Sp) of input class: Compute the local separation map and show it as
an overlay.
Bone > Single bone skeletonization of input class: Compute the center line path of a class along its
principal direction. Results are stored as a .csv file. Also, the cross-sectional area orthogonal to the
principal direction is computed at slices with the spacing of half a voxel size. Then the largest fitting
sphere is provided at each position which is computed using a distance map. The path position at each
slice is the position of the largest fitting sphere. After computation, the path is shown as a new class
“Path” which replaces the input class, which can be restored using “Undo”. To understand this
functionality, please try it out on a sphere or a cylinder (Mouse mode toolbar > “Create region”). This
function requires isotropic voxel sizes.

Help Menu
The help menu has the following entries:
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Help > Show manual: Open this manual in a pdf viewer.
Help > Mouse modes: Show a list of the mouse modes.
Help > Tutorials: The tutorials include a list of tutorial videos showing how to use the software (See
the tutorial list below). These videos have subtitles in English, German, Chinese, and French, which
can be activated with the VLC player. The following tutorials exist already:
> General > Introduction, Upper toolbar, Mouse mode toolbar, Cropping, Project files,
Scribbles, Fill region, Image fusion, Large data set, 3D printing, Atlas Mouse Brain CT
> CT > Liver tumors, Bone implant, Trabecular bone, Bone cavity, Bone defect,
Calcifications, Cortical bone, Fat segmentation, Lung metastases, Mouse body
segmentation, Cardiac imaging, Lung segmentation, Organ segmentation, Walnut
> Optical > BLI-CT, Spectral unmixing, Spectral unmixing MILabs
> PET/SPECT > PET-SPECT-CT, PET-CT (dynamic), PET tracer (dynamic), SPECT
phantom, PET CT 4 mice
> MRI > Relaxometry T2, MRI rat tumor T2, Mouse brain
> Other > US cineloop tumor
> Info: Provide some information about the tutorial (imaging modality and
sample).
> Load example data set: Load an imaging data set and a segmentation, if
available.
> Show video: Show the respective video.
> Show white paper: Open the white paper about the video and data set.

Help > CPU info: Show information about the central processing unit (CPU).
Help > GPU info: Show information about the graphics processing unit (GPU).
Help > How to report a bug: Show how to report a bug best so that it can be found and fixed.
Help > How to cite this software: When using the software, please mention the name of the software
(Imalytics Preclinical) and cite this paper: F. Gremse, et al., “Imalytics Preclinical: Interactive Analysis
of
Biomedical
Volume
Data,”
Theranostics.
2016
Jan
1;6(3):328-41.
(https://pubmed.ncbi.nlm.nih.gov/26909109/)
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When using CT-FMT protocol, please cite this paper: F. Gremse et al., “Hybrid µCT-FMT imaging and
image analysis,” J Vis Exp. 2015 Jun 4;(100):e52770.
(https://www.ncbi.nlm.nih.gov/pmc/articles/PMC4512251/)
When using the improved FMT reconstruction, please cite this paper: F. Gremse et al., “Absorption
reconstruction improves biodistribution assessment of fluorescent nanoprobes using hybrid
fluorescence-mediated tomography,” Theranostics. 2014 Jul 26;4(10):960-71.
(https://pubmed.ncbi.nlm.nih.gov/25157277/)
When using the software for stenosis measurement, please cite this paper: F. Gremse et al., “Virtual
elastic sphere processing enables reproducible quantification of vessel stenosis at CT and MR
angiography,” Radiology. 2011 Sep;260(3):709-17. (https://pubmed.ncbi.nlm.nih.gov/21788527/)
Help > License info: Show the license of the installed program, i.e., the remaining duration and which
modules are activated.
Help > About: Show information about the program.
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5. Frequently asked questions
Table of contents
1.

FREQUENTLY ASKED QUESTIONS ........................................................................................................... 56
GENERAL ............................................................................................................................................................. 56
1 What file formats are supported by Imalytics Preclinical? ........................................................................ 56
2 How can I provide feedback if there is a problem with the software? ...................................................... 57
3 How can I save a fly-through movie of my image?.................................................................................... 57
SCRIBBLES ............................................................................................................................................................ 57
1 I cannot draw scribbles- why? ................................................................................................................... 57
2 Can I delete the scribbles once I drew them? ............................................................................................ 57

General
1 What file formats are supported by Imalytics Preclinical?
The following file formats are supported by Imalytics Preclinical:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Analyze (.hdr/.img)
Nifti (.nii/.hdr)
MicroPET (.hdr)
Vevo770 (.vsi)
Vevo2100 B-Mode, NonLinear, Linear (.bimg/.animg/.nbimg)
CT-Imaging Files (.mif/.mifx)
TIFF (.tif/.tiff)
MetaImageHeader (.mhd)
Sparse MHD (.sdr)
PAR/REC (.PAR)
NRRD (.nrrd)
NRRD Header Files (.nhdr)
PNG (.png)
JPEG (.jpg)
SkyScan Recons (.log)
VFF files (.vff)
VOX files (.VOX)
Bitmap files (.bmp)
Aspect Files (.DAT)
CT Projections (.ori)
DICOM (.dcm)
DICOM
Grace File Format (.gff)
Super marty View Files (.smv)

DICOM files can be converted to nifty using Chris Rorden’s dcm2niigui program
(http://people.cas.sc.edu/rorden/mricron/dcm2nii.html).

2 How can I provide feedback if there is a problem with the software?
A screenshot of the error message will be very helpful for troubleshooting. In addition to the
screenshot image, please include a short description of the problem and the error file you are having
trouble with. Send them to support@gremse-it.com and include your preferred email address and
phone number in the message.

3 How can I save a fly-through movie of my image?
First, open the context menu by clicking the right mouse button in one of the 2D slice viewing panels.
Choose Save image/movie > fly through or time) for 2D. This operation will create a .wmv or .mp4
movie flying through the slices. Set the distance in the data set [mm] (negative values inverts the
direction), the duration of the movie [s], and the desired file size [MB] (0 for any). Select your
parameters and press apply. When the movie is ready, a window with “Movie is rendered.” appears.
Press OK to continue. For 3D movies, click the right mouse button in the 3D rendering and select Save
image/movie > Save rotation/time movie. Choose your movie parameters (duration, rotation, time
steps, and desired file size) and save the movie as .wmv or .mp4 file.

Scribbles
1 I cannot draw scribbles- why?
If you try to draw scribbles and cannot see them, please check the following points:
(i)

(ii)
(iii)

Make sure that you enabled sribble drawing mode by pressing the vertical toolbar/
mouse action button “Draw scribbles“ (pencil cursor will appear) or by pressing SHIFT+
left mouse button (no special cursor appears).
Do you try to draw scribbles in 3D view. This is not possible. Only in the 2D views.
Toogle the button “Show scribbles“ in the upper toolbar.If this button is inactivated, you
can draw scribbles but you will not see them.

2 Can I delete the scribbles once I drew them?
If you want to delete all scribbles, press F1. If you want to delete only a few scribbles that are
mislocated, use the “Cut“ function of the settings toolbar that appears when you press the mouse
action button “Draw scribbles“.

Licences
1 Where do I find information about my licence?
For licence information, for example, when the licence expires, press the Menu item Help > Licence
information. All relevant information can be found there:
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2 My licence is expired- how can I extend my licence/ get another licence?
When you try to start Imalytics Preclinical and the software tells you that checking date range or
software name was not successful, please copy the shown hardware hash and send it to
licenses@gremse-it.com. Another licence file will be provided via eMail.
If you already have an up-to-date licence file select this licence file or copy it to the licence folder and
press `Try Again`.

To be continued….
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